Service bitninja.io seems to be down

Major incident bitninja.io
3 minutes

Updates

Resolved

Service is back up.

September 23, 2019 · 15:17 CEST
Issue

Our monitoring system has found out the service bitninja.io is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

September 23, 2019 · 15:14 CEST

← Back