Service bitninja.io seems to be down

Major incident bitninja.io
52 minutes, 16 seconds

Updates

Resolved

Service is back up.

June 19, 2019 · 13:46 CEST
Issue

Our monitoring system has found out the service bitninja.io is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

June 19, 2019 · 12:54 CEST

← Back